GanttProject

From The Collaboratory

Jump to: navigation, search

Contents

Description

GanttProject is a free Open Source desktop software tool for project planning and management.

Availability

GanttProject can be obtained from the GanttProject website for a variety of different platforms. GanttProject is installed in Frey 254 and can be accessed using the Application Launcher in Frey 145 and Frey 166. (If, when attempting to run GanttProject, you get an error message about needing the Java Runtime Environment, install the Java Development Kit Command Line from teh Application Launcher.)

Training

GanttProject is fairly self-explanatory, but if you wish some introduction to the software and how to use it, there is an 8 minute introductory video available.

Tips

Displaying The Gantt Chart in the Wiki

If you upload the Gantt Chart file directly to the wiki and then create a link to it, the web browser will show the file in an xml format which is difficult to interpret. However, a stylesheet has been created and placed on the wiki which will allow the file to be displayed in a manner similar to the way it shows in GanttProject. Using this stylesheet eliminates the need to download and open the file in GanttProject if all you want to do is view the Gantt Chart. Note that to edit the GanttProject file, you still need to download the file and open it in GanttProject.

To use the stylesheet, you need to modify the GanttProject file using the following process.

  1. Open the GanttProject file with WordPad or NotePad. (Do NOT use Microsoft Word to open the file.) The easiest way to do this is to right click on the file and select Open With ..., WordPad.
  2. Add the following after the first line of the file:
    <?xml-stylesheet type="text/xsl" href="ganttproject_format.xsl" alternate="no" ?>
  3. The first two lines of the file will now be as follows:
    <?xml version="1.0" encoding="UTF-8"?>
    <?xml-stylesheet type="text/xsl" href="ganttproject_format.xsl" alternate="no" ?>
  4. Using File, Save As..., you can save the file using any name you want, but change the extension (the part after the .) to .xml.

If you upload this file to the wiki and create a link to it, clicking on the link will cause the file to be displayed as a Gantt Chart. The line added to the file in step 2 will not prevent GanttProject from opening the file. Changing the extension in step 4 will also not prevent GanttProject from opening the file. The only difference is that because of the change of extension, the file will not automatically be associated with GanttProject, that is, double-clicking on the file will not automatically launch GanttProject. You will have to either open GanttProject first and then use Project, Open or right click and select Open With ..., GanntProject to open the file in GanttProject.

Note that the stylesheet works with Internet Explorer, but works better when viewing the wiki with FireFox.

Changing the Scale of the Calendar

The scale on the calendar can be changed to show a more detailed or more overall view. The scale that is showing for the calendar also determines the scale that is used when printing the Gantt chart.

  • At the largest setting, the calendar will show individual days as fairly wide columns. A header is placed over the columns for the days of a particular week and the number of the week in the year is placed in that header.
  • At smaller settings, the calendar will show individual days as thinner columns. A header is placed over the columns for the days of a particular month and the name of the month is placed in that header.
  • At still smaller settings, the calendar shows the weeks as individual columns with the number of the week in the year as the label. A header is placed over the weeks which correspond to a particular month and the name of the month is placed in that header.
  • At the smallest settings, the calendar shows the weeks as individual columns with the number of the week in the year as the label and the header over the weeks which correspond to a particular year shows what year those weeks are for.

To change between the different settings, the Zoom Out (a magnifying glass with a - sign in it) and Zoom In a magnifying glass with a + sign in it) icons in the tool bar can be used. Simply clicking on one of those tools will either increase the setting (Zoom In) or decrease the setting (Zoom Out). Alternatively, the same effect can be achieved if Preview before print is selected from the Project menu and the Narrow Chart or Widen Chart buttons are selected.

Note that the scale setting is saved with the file, so once the setting it set, it will be remembered from one session with GanttChart to the next.

Exporting the Gantt Chart as An Image for Use on the Wiki

To create an image of the Gantt Chart that can used on the wiki (or some other web site in which you cannot expect viewers to have access to GanttProject), use the Export function. Select Export under the Project menu. Select the Raster image file radio button, choose PNG file format from the File format drop-down menu. (For this type of image, a png file is much smaller than a jpeg file.) Select the Next button and then choose a name and location for the file. Select the OK button to create the image file. This file can then be uploaded to the wiki.

Printing

To print the chart, Print... under the Project menu should be selected. Because GanttProject is based on Java, the Print window that opens will have a slightly different format than Windows print windows usually use. The most important thing to note, however, is that the default paper size is A4. Since our printers are not set up for A4 paper, you must change the paper size. This can be done by selecting the Page Setup tab in the Print window and choosing Letter from the Size drop-down menu (you may have to scroll up to see it).

Setting Start and End Dates for Printing

When the Gantt Chart is printed, the start and end dates will match (roughly) the dates that are showing on the screen. The dates that should be printed out can also be set more directly by using the Preview before print window which can be obtained from the Project menu. In this window, the Start date and the End date can be set or the whole project can be printed out by selecting the Whole project button. Clicking on the Print icon will cause the chart to print out using these start and end dates.

Note that because the U.S. standard Letter size paper is not built in to GanttChart, the Preview window will not accurately show the total number of pages that will print out or where the page breaks will fall.

Printing Task Start and End Dates

GanttProject does not currently print start and end dates in columns after the name of the task as they appear in Task window on the screen. (In fact, it does not print any of the columns in the Task window other than the task name.) There are two options which can be used to print out the start and end dates (or any other data that can be shown in columns after task name in the Task window. The first option described below is probably the more useful.

  1. Add start and end dates to the task bars. By selecting Chart options under the View menu, you can get to the Gantt chart settings window. (You can also get to this chart by selecting Gantt Chart in the Settings window.) In this window, you can change various options about how the Gantt Chart is shown. To show the start and end dates, in the drop down menus in the Task details section, select Task start/end dates and then select OK. The task start and end dates will now be shown above the task bars. These will also appear in this position when the chart is printed out.
  2. Create a pdf report. A pdf report of the project can be created by selecting Export in the Project menu. In the Export wizard window which opens select the PDF report radio button. You can choose a theme from the drop down window. They will all show in the report the task start and end date or the data from any other columns showing in the Task window. (Samara will only show those showing in the window while the others will show all of the columns.) Select the Next button and in the next window, choose location and file name of the file to be save. Choosing OK will cause the pdf report to be created. This file contains various pages showing, among other things, the tasks with their start and end dates.
Personal tools
Navigation